Hey there! Sign in to join this conversationNew here? Join for free

My Laptop doesn't recognise my S4 anymore, help please Watch

    • Thread Starter
    Offline

    15
    ReputationRep:
    Hi,

    Basically, I'm used to uploading files through my Samsung Galaxy S4, to my Laptop which is on a Windows 8 Os system(the latest update), with little to no problem. The last time I did it was summer last year.

    But today, just to download more photos, I connected my Phone to my Laptop and it couldn't recognise it, all it just did was charge the phone.

    I tested if the problem was from the Laptop by connecting a USB stick to all the USB ports on it, but turned out false.

    So I tested if it was from my latest USB cable, by trying different cables between both devices; same result.

    So now I'm left with the assumption that the problem was from my phone, which is why I'm asking you guys to tell me how to sort this out.
    Offline

    16
    ReputationRep:
    Have you tried the original USB cable for the S4? Some people have reported that once they got the "correct" cable, it worked. You could also try some trouble shooting steps here: https://www.youtube.com/watch?v=9qAFgn-tZUU
    Offline

    0
    ReputationRep:
    (Original post by kenni12)
    Hi, Basically, I'm used to uploading files through my Samsung Galaxy S4, to my Laptop which is on a Windows 8 Os system(the latest update), with little to no problem. The last time I did it was summer last year.
    Your laptop might have amnesia. Take it to your GP
    • Thread Starter
    Offline

    15
    ReputationRep:
    (Original post by Hadooka)
    Your laptop might have amnesia. Take it to your GP
    Haha very funny:unimpressed:
    • Thread Starter
    Offline

    15
    ReputationRep:
    (Original post by mashbbk)
    Have you tried the original USB cable for the S4? Some people have reported that once they got the "correct" cable, it worked. You could also try some trouble shooting steps here: https://www.youtube.com/watch?v=9qAFgn-tZUU
    Checked the video out, tried debugging mode as the guy suggested and it worked out.

    Thanks man, did you ever have that problem?
    Offline

    16
    ReputationRep:
    (Original post by kenni12)
    Checked the video out, tried debugging mode as the guy suggested and it worked out.

    Thanks man, did you ever have that problem?
    No I haven't personally but I am aware that phones can get quirky when connecting to computers...

    Glad it worked for you!
 
 
 
  • See more of what you like on The Student Room

    You can personalise what you see on TSR. Tell us a little about yourself to get started.

  • Poll
    Will you be richer or poorer than your parents?
    Useful resources

    Quick link:

    Unanswered mobile phones threads

    Groups associated with this forum:

    View associated groups
  • See more of what you like on The Student Room

    You can personalise what you see on TSR. Tell us a little about yourself to get started.

  • The Student Room, Get Revising and Marked by Teachers are trading names of The Student Room Group Ltd.

    Register Number: 04666380 (England and Wales), VAT No. 806 8067 22 Registered Office: International House, Queens Road, Brighton, BN1 3XE

    Quick reply
    Reputation gems: You get these gems as you gain rep from other members for making good contributions and giving helpful advice.