Turn on thread page Beta
    • Thread Starter
    Offline

    4
    ReputationRep:
    Ok so in my house we have an ethernet cable which I just pop into my laptop and the internet comes on in a flash. All is dandy.
    But this morning I tried taking that ethernet cable out and inserting it into my PC and the internet doesn't work. It says that there is trouble finding the IP address and there is 'limited or no connectivity'.
    Why does the cable allow me to access the internet on my laptop and not the PC? I'm sorry about this but I'm awful with computers. :o:

    Thanks!
    Offline

    16
    ReputationRep:
    Hm, strange.

    Do you have the 'Obtain an IP address automatically' option ticked in your TCP/IP settings of your Local Area Connection?
    Offline

    14
    Try going to Control Panel > Network (or whatever it's called) and then right-click&Repair on your connection.
    • Thread Starter
    Offline

    4
    ReputationRep:
    (Original post by Misogynist)
    Hm, strange.

    Do you have the 'Obtain an IP address automatically' option ticked in your TCP/IP settings of your Local Area Connection?
    Erm . . . how would I go about checking that? I'm not sure. :o:
    • Thread Starter
    Offline

    4
    ReputationRep:
    (Original post by Sports Racer)
    Try going to Control Panel > Network (or whatever it's called) and then right-click&Repair on your connection.
    Yeah I tried that but it didn't seem to work.
    Offline

    3
    ReputationRep:
    what ip does your computer give?
    Offline

    16
    ReputationRep:
    (Original post by HappinessHappening)
    Erm . . . how would I go about checking that? I'm not sure. :o:
    Start -> Settings -> Network Connections -> Right click 'Local Area Connection' -> Scroll down to 'Internet Protocol (TCP/IP) -> Properties -> Make sure that the 'Obtain IP address automatically' option is ticked.
    Offline

    3
    ReputationRep:
    (Original post by Misogynist)
    Start -> Settings -> Network Connections -> Right click 'Local Area Connection' -> Scroll down to 'Internet Protocol (TCP/IP) -> Properties -> Make sure that the 'Obtain IP address automatically' option is ticked.
    I'm suspecting it isn't this, as if its manually assigned it'll just say 'connected'.

    Not a bad first call though
    Offline

    16
    ReputationRep:
    (Original post by samba)
    I'm suspecting it isn't this, as if its manually assigned it'll just say 'connected'.

    Not a bad first call though
    Yes, but it won't connect if the IP settings don't correspond with the IP range assigned by the DHCP if values have been entered in the TCP/IP field.

    The modem is DHCP enabled, 'cause his laptop connects automatically. So I think that'll fix it.

    There's really not enough information to make another guess, so
    • Thread Starter
    Offline

    4
    ReputationRep:
    (Original post by Misogynist)
    Start -> Settings -> Network Connections -> Right click 'Local Area Connection' -> Scroll down to 'Internet Protocol (TCP/IP) -> Properties -> Make sure that the 'Obtain IP address automatically' option is ticked.
    Yeah it's ticked all right. This is very confusing. Perhaps it's the firewall or something?

    Thank you for trying to help me. :yep:
    Offline

    16
    ReputationRep:
    (Original post by HappinessHappening)
    Yeah it's ticked all right. This is very confusing. Perhaps it's the firewall or something?

    Thank you for trying to help me. :yep:
    Well, disable the firewall and see if it works. If it doesn't, it's something else.

    What kind of a modem is this? Is it a router? Are you trying to connect both computers at once?

    Also, double click your network connection in your taskbar and click on support, post the screenshot here. If you don't know how to take a screen shot then write down the values here. (This is for the laptop you're on now by the way.)
    Offline

    1
    ReputationRep:
    Do you know if you have MAC address filtering enabled on your router/modem?
    Offline

    3
    ReputationRep:
    (Original post by Misogynist)
    Yes, but it won't connect if the IP settings don't correspond with the IP range assigned by the DHCP if values have been entered in the TCP/IP field.

    The modem is DHCP enabled, 'cause his laptop connects automatically. So I think that'll fix it.

    There's really not enough information to make another guess, so
    Aye, what I meant is that it won't popup with the 'limited or no connectivity' thing, as it'll be stateless :p:

    you're right, the DHCP server is fine, and theres not really much info.

    OP, try this: go to start>run and type 'cmd' - then hit ok and type the following into the command box that'll appear

    Code:
    netsh int ip reset c:\resetlog.txt
    That'll reset your tcp/ip stack.
    • Thread Starter
    Offline

    4
    ReputationRep:
    (Original post by Misogynist)
    Well, disable the firewall and see if it works. If it doesn't, it's something else.

    What kind of a modem is this? Is it a router? Are you trying to connect both computers at once?

    Also, double click your network connection in your taskbar and click on support, post the screenshot here. If you don't know how to take a screen shot then write down the values here. (This is for the laptop you're on now by the way.)
    Yep it's a router I believe from Virgin media. I'm not trying to connect both at once. I only have one cable.


    IP address: 82.25.2.81
    Subnet mask: 255.255.252.0
    Default gateway: 82.25.0.1

    Is that what you are after?
    Offline

    16
    ReputationRep:
    (Original post by nadnerb)
    Do you know if you have MAC address filtering enabled on your router/modem?
    He doesn't know what an IP address is so I doubt he's enabled MAC filtering and put in his laptops details correctly. Unless a wee man came around to set it up for him..
    Offline

    0
    ReputationRep:
    (Original post by HappinessHappening)
    Erm . . . how would I go about checking that? I'm not sure. :o:
    First of all Restart your router and PC - try connecting.

    Can you check your ip address please?

    Go to start --> run
    type cmd and hit enter
    in the black window, type ipconfig and hit enter.

    You should have an ipaddress come up, what is the start of it? I suspect 169.x.x.x
    Type ipconfig /renew

    Try going into network connections, right click the connection, delete it and re-create.
    Offline

    16
    ReputationRep:
    (Original post by HappinessHappening)
    Yep it's a router I believe from Virgin media. I'm not trying to connect both at once. I only have one cable.


    IP address: 82.25.2.81
    Subnet mask: 255.255.252.0
    Default gateway: 82.25.0.1

    Is that what you are after?
    Yes, good, good. Now here's what you should do. Go in your TCP/IP settings on the PC, and put in these values:

    IP Address: 82.25.2.82
    Subnet Mask: 255.255.252.0
    Gateway: 82.25.0.1

    Leave the DNS fields blank for now (Or if you want to be completely sure, you can click 'Details' in support and find out your values for DNS1 and DNS2.)

    Now plug in your PC and enable your LAN. If it's limited, repair. Should work.
    • Thread Starter
    Offline

    4
    ReputationRep:
    Argh . . . it didn't like that either! That's really odd because it no longer says limited or no connectivity (with that yellow exclamation mark triangle symbol) but the internet still isn't coming up.
    Offline

    3
    ReputationRep:
    (Original post by HappinessHappening)
    Argh . . . it didn't like that either! That's really odd because it no longer says limited or no connectivity (with that yellow exclamation mark triangle symbol) but the internet still isn't coming up.
    Did you reset the TCP/IP stack as I told you to?

    Also, it wont work as your laptop already has that IP in the router tables. You'd need to Disconnect your laptop.
    • Thread Starter
    Offline

    4
    ReputationRep:
    (Original post by samba)
    Did you reset the TCP/IP stack as I told you to?

    Also, it wont work as your laptop already has that IP in the router tables. You'd need to Disconnect your laptop.
    Yeah I did both of those things . . . but still no internet on the PC
 
 
 
Poll
Black Friday: Yay or Nay?

The Student Room, Get Revising and Marked by Teachers are trading names of The Student Room Group Ltd.

Register Number: 04666380 (England and Wales), VAT No. 806 8067 22 Registered Office: International House, Queens Road, Brighton, BN1 3XE

Write a reply...
Reply
Hide
Reputation gems: You get these gems as you gain rep from other members for making good contributions and giving helpful advice.