kw310
Badges: 3
Rep:
?
#1
Report Thread starter 3 weeks ago
#1
I am getting so frustrated with UCAS this year, I had no problem with applying last year so I have no idea what has happened but I cannot for the life of me figure out how to apply. Every time I click 'apply' for a course it just takes me back to the 'Hub' and there isn't anywhere for me to fill in an application or register. I am so confused, can someone help?
Last edited by kw310; 3 weeks ago
1
reply
McGinger
Badges: 16
Rep:
?
#2
Report 3 weeks ago
#2
Its a new system this year - and there are glitches.

Try deleting all cookies and/or trying a different internet browser.
0
reply
kw310
Badges: 3
Rep:
?
#3
Report Thread starter 3 weeks ago
#3
Ah so it's most likely the actual site rather than me being stupid? OK that makes me feel a bit better, I tried a different browser and deleted all cookies and it's still doing the same but I'll ring UCAS tomorrow and see if they can help, thank you!
0
reply
X

Quick Reply

Attached files
Write a reply...
Reply
new posts
Back
to top
Latest
My Feed

See more of what you like on
The Student Room

You can personalise what you see on TSR. Tell us a little about yourself to get started.

Personalise

Have you made your mind up on your five uni choices?

Yes, and I've sent off my application! (237)
57.38%
I've made my choices but havent sent my application yet (53)
12.83%
I've got a good idea about the choices I want to make (46)
11.14%
I'm researching but still not sure which universities I want to apply to (36)
8.72%
I haven't started researching yet (23)
5.57%
Something else (let us know in the thread!) (18)
4.36%

Watched Threads

View All