The Student Room Group

King's PPE acting up weird on Student Finance England...

I don't know if anyone else has experienced this, this year, but I know someone did last year in a post I'll link below and I tried responding to it but I received an error trying to respond as well?!

I'm trying to put in PPE at King's but it's saying put in a valid code and title and even though it comes up as an option, after I press continue, it brings me back to this, with some weird, Â, symbol next to it. I've tried just putting in the course code, just the title and the full title of course but still no luck. I tried putting in other courses like Philosophy and Mathematics, Economics and Computer science; lots of them to see if it's the system or my course and it went through...

Has anyone else had this problem this year, and if so, how did you resolve it? I'll attach an image underneath somewhere

Link to last year's case: https://www.thestudentroom.co.uk/showthread.php?t=7345868
Screenshot 2024-04-25 173104.png
(edited 1 month ago)
Original post by JVorJrose
I don't know if anyone else has experienced this, this year, but I know someone did last year in a post I'll link below and I tried responding to it but I received an error trying to respond as well?!
I'm trying to put in PPE at King's but it's saying put in a valid code and title and even though it comes up as an option, after I press continue, it brings me back to this. I've tried just putting in the course code, just the title and the full title of course but still no luck. I tried putting in other courses like Philosophy and Mathematics, Economics and Computer science; lots of them to see if it's the system or my course and it went through...
Has anyone else had this problem this year, and if so, how did you resolve it? I'll attach an image underneath somewhere
Link to last year's case: https://www.thestudentroom.co.uk/showthread.php?t=7345868
Attachment not found

Hi there,

You need to select the course from the drop down when applying for the funding and not manually enter it as the application won't go forward unless it's selected. Thanks, Jason
The course 'Philosophy, Politics & Economics (3YR)' is on the database so if you select this from the drop down it will allow you to move forward.

Thanks, Jason
Reply 3
Original post by SFE Jason
The course 'Philosophy, Politics & Economics (3YR)' is on the database so if you select this from the drop down it will allow you to move forward.
Thanks, Jason

Hi SFE Jason!

Oh but I have - I did select the course from the drop down, I tried it for the other courses too from the drop down and it worked but not Philosophy, Politics & Economics; is it a problem on King's behalf then?
Original post by JVorJrose
Hi SFE Jason!
Oh but I have - I did select the course from the drop down, I tried it for the other courses too from the drop down and it worked but not Philosophy, Politics & Economics; is it a problem on King's behalf then?

Thanks for your response. Not from what we've been advised. If you want to contact us via the live chat in your account we can check your application just to make sure there's nothing else preventing you from selecting the course. Thanks, Jason
Reply 5
You are most welcome; thank you for your response too!
Oh really, ah alright sure! Thank you very much I'll head right over to SFE
Original post by JVorJrose
You are most welcome; thank you for your response too!
Oh really, ah alright sure! Thank you very much I'll head right over to SFE

Thanks. Have a good day. Thanks, Jason
Reply 7
Original post by SFE Jason
Thanks. Have a good day. Thanks, Jason

Thank you I hope you have a good day too, but I've been messaging in the live chat on SFE and there still doesn't seem to be a fix for this issue, I'm stumped
Original post by JVorJrose
Thank you I hope you have a good day too, but I've been messaging in the live chat on SFE and there still doesn't seem to be a fix for this issue, I'm stumped

What did they advise you to do? As we can't see your application on here (as it's general queries), we do advise using those methods above to getting this resolved. Alternatively, do try and clear your browser history and cache and log back in. Thanks, Jason (also we are now closed until tomorrow at 9.am) any other questions then do use the live chat (open till 5.30) or 0300 100 0607 (open till 8.pm) just to save a delay in response. Thanks, Jason
Reply 9
Original post by SFE Jason
What did they advise you to do? As we can't see your application on here (as it's general queries), we do advise using those methods above to getting this resolved. Alternatively, do try and clear your browser history and cache and log back in. Thanks, Jason (also we are now closed until tomorrow at 9.am) any other questions then do use the live chat (open till 5.30) or 0300 100 0607 (open till 8.pm) just to save a delay in response. Thanks, Jason

Alright then I'll try to clear my browser cache or something, thank you Jason
Reply 10
Update: It's been Resolved! I think what I tried doing was putting in a random course I put in economics, then completed the whole section then went Back and changed it again to PPE, I clicked on the backwards arrow in the top left corner to go back and then went forward again and then it somehow allowed it I- I don't even know how on earth this has just happened, but I am so so happy, Oh my Lord. Thank you @SFE Jason for your support. It's self-resolved somehow😌
Original post by JVorJrose
Update: It's been Resolved! I think what I tried doing was putting in a random course I put in economics, then completed the whole section then went Back and changed it again to PPE, I clicked on the backwards arrow in the top left corner to go back and then went forward again and then it somehow allowed it I- I don't even know how on earth this has just happened, but I am so so happy, Oh my Lord. Thank you @SFE Jason for your support. It's self-resolved somehow😌

That's great, we're glad to hear this - we'll pass this on to our team and let them know how you resolved this.

Thanks, Graeme

Quick Reply

Latest

Trending

Trending