Turn on thread page Beta

Empire Earth compatibility watch

    • Thread Starter
    Offline

    2
    ReputationRep:
    Hey, I have the origional Empire Earth game, and it always worked fine on my old XP and 98 computers.

    Recently got a new laptop with Vista on it, and the game only runs if I run it as an administrator, BUT it only lets me go through the menus, the game stops responding if I try to start an actual game. Does anyone know what I can do to try and fix this? I've installed the patches etc, and don't know what else to do...
    • Thread Starter
    Offline

    2
    ReputationRep:
    Oh and I've also run it in windows XP compatibility mode, that didn't work either
 
 
 
The home of Results and Clearing

2,502

people online now

1,567,000

students helped last year
Poll
How are you feeling about GCSE results day?
Useful resources

Quick link:

Unanswered gaming threads

Groups associated with this forum:

View associated groups

The Student Room, Get Revising and Marked by Teachers are trading names of The Student Room Group Ltd.

Register Number: 04666380 (England and Wales), VAT No. 806 8067 22 Registered Office: International House, Queens Road, Brighton, BN1 3XE

Write a reply...
Reply
Hide
Reputation gems: You get these gems as you gain rep from other members for making good contributions and giving helpful advice.